summaryrefslogtreecommitdiff
path: root/lib/safestack/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2015-08-27 22:23:27 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2015-08-27 22:23:27 +0000
commit7eedde663ebef4e9d1d287efd568c9cd7094811f (patch)
treee4c74d994bfcd147e6ee4cc2f55f932be45f9bb1 /lib/safestack/CMakeLists.txt
parentb980cb13021238b0a6ff304a853c7fb919c297fc (diff)
[CMake] Unify build rules for sanitizer_common for Apple and non-Apple platforms.
Additionally, link safestack runtime on OS X with nolibc version of sanitizer_common runtime, as we do on Linux. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@246227 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/safestack/CMakeLists.txt')
-rw-r--r--lib/safestack/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/safestack/CMakeLists.txt b/lib/safestack/CMakeLists.txt
index f5d31225d..9c11bb6f7 100644
--- a/lib/safestack/CMakeLists.txt
+++ b/lib/safestack/CMakeLists.txt
@@ -15,6 +15,7 @@ if(APPLE)
SOURCES ${SAFESTACK_SOURCES}
$<TARGET_OBJECTS:RTInterception.osx>
$<TARGET_OBJECTS:RTSanitizerCommon.osx>
+ $<TARGET_OBJECTS:RTSanitizerCommonNoLibc.osx>
CFLAGS ${SAFESTACK_CFLAGS}
PARENT_TARGET safestack)
else()