summaryrefslogtreecommitdiff
path: root/lib/profile/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-03-31 13:45:36 +0000
committerAlexey Samsonov <samsonov@google.com>2014-03-31 13:45:36 +0000
commite18b78588ef4aac46204c7b23d076221993edade (patch)
tree8620e3e8c88fce96c2a48dc6650b8cd51f5e675c /lib/profile/CMakeLists.txt
parenteba4cc9092ffa0fb41c1b25491857f6f9b5b01e4 (diff)
[CMake] Rename add_compiler_rt_static_runtime to add_compiler_rt_runtime.
Soon there will be an option to build compiler-rt parts as shared libraries on Linux. Extracted from http://llvm-reviews.chandlerc.com/D3042 by Yuri Gribov. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@205183 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/profile/CMakeLists.txt')
-rw-r--r--lib/profile/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/lib/profile/CMakeLists.txt b/lib/profile/CMakeLists.txt
index 526017f2e..8d0a5d0d0 100644
--- a/lib/profile/CMakeLists.txt
+++ b/lib/profile/CMakeLists.txt
@@ -25,8 +25,7 @@ else()
InstrProfilingRuntime.cc)
foreach(arch ${PROFILE_SUPPORTED_ARCH})
- add_compiler_rt_static_runtime(clang_rt.profile-${arch}
- ${arch}
+ add_compiler_rt_runtime(clang_rt.profile-${arch} ${arch} STATIC
SOURCES ${PROFILE_SOURCES})
add_dependencies(profile clang_rt.profile-${arch})
endforeach()