summaryrefslogtreecommitdiff
path: root/lib/profile/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2016-01-08 02:03:25 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2016-01-08 02:03:25 +0000
commitd1cb66bba2b64c7d34d24f433973b9700eead7d4 (patch)
treec984377649825591a4ee9151f13e614f2758ab47 /lib/profile/CMakeLists.txt
parentc040a742e6cc6f34d6fd1b7d10241c076b66e6de (diff)
profile: Do not pass -fPIC on Windows.
Unbreaks clang-cl build (cl warns on this flag, clang-cl errors on it). git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@257136 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/profile/CMakeLists.txt')
-rw-r--r--lib/profile/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/lib/profile/CMakeLists.txt b/lib/profile/CMakeLists.txt
index 80a4b6696..17eb48a5b 100644
--- a/lib/profile/CMakeLists.txt
+++ b/lib/profile/CMakeLists.txt
@@ -45,9 +45,6 @@ if(UNIX)
set(EXTRA_FLAGS
-fPIC
-Wno-pedantic)
-else()
- set(EXTRA_FLAGS
- -fPIC)
endif()
if(COMPILER_RT_TARGET_HAS_ATOMICS)