summaryrefslogtreecommitdiff
path: root/lib/profile/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-03-21 18:29:15 +0000
committerDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-03-21 18:29:15 +0000
commitad46436a217cc8a17a5bd8948cda0bd9dd6788c4 (patch)
tree69fee8a7849f75899cd3fa0e138968d0abec3ac5 /lib/profile/CMakeLists.txt
parent10692cccd92c84573854be22f01544324da328cf (diff)
InstrProf: Reorganize files; no functionality change
Move functions around to prepare for some other changes. - Merge InstrProfilingExtras.h with InstrProfiling.h. There's no benefit to having these split. - Rename InstrProfilingExtras.c to InstrProfilingFile.c. - Split actual buffer writing code out of InstrProfiling.c into InstrProfilingBuffer.c. - Drive-by corrections of a couple of header comments. <rdar://problem/15943240> git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@204497 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/profile/CMakeLists.txt')
-rw-r--r--lib/profile/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/lib/profile/CMakeLists.txt b/lib/profile/CMakeLists.txt
index 949e174b4..526017f2e 100644
--- a/lib/profile/CMakeLists.txt
+++ b/lib/profile/CMakeLists.txt
@@ -6,9 +6,10 @@ if(APPLE)
set(PROFILE_SOURCES
GCDAProfiling.c
InstrProfiling.c
+ InstrProfilingBuffer.c
+ InstrProfilingFile.c
InstrProfilingPlatformDarwin.c
- InstrProfilingRuntime.cc
- InstrProfilingExtras.c)
+ InstrProfilingRuntime.cc)
add_compiler_rt_osx_static_runtime(clang_rt.profile_osx
ARCH ${PROFILE_SUPPORTED_ARCH}
@@ -18,9 +19,10 @@ else()
set(PROFILE_SOURCES
GCDAProfiling.c
InstrProfiling.c
+ InstrProfilingBuffer.c
+ InstrProfilingFile.c
InstrProfilingPlatformOther.c
- InstrProfilingRuntime.cc
- InstrProfilingExtras.c)
+ InstrProfilingRuntime.cc)
foreach(arch ${PROFILE_SUPPORTED_ARCH})
add_compiler_rt_static_runtime(clang_rt.profile-${arch}