summaryrefslogtreecommitdiff
path: root/lib/profile/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-08-18 18:35:18 +0000
committerChris Bieneman <beanz@apple.com>2015-08-18 18:35:18 +0000
commit4e3b842cedf82fce9e0438e41db2997edc2b5bac (patch)
tree6be1646334cbc0be8ffdfe2719a630a655fee29d /lib/profile/CMakeLists.txt
parent7fcc1595598f1f7c9cd94f0f2e891e2fbd257ece (diff)
[CMake] Backing out part of r245317. Turns out safestack and profile don't work correctly on the iOS simulator and enabling it breaks tests.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@245326 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/profile/CMakeLists.txt')
-rw-r--r--lib/profile/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/profile/CMakeLists.txt b/lib/profile/CMakeLists.txt
index fabac1596..a21ec3053 100644
--- a/lib/profile/CMakeLists.txt
+++ b/lib/profile/CMakeLists.txt
@@ -11,7 +11,7 @@ set(PROFILE_SOURCES
InstrProfilingUtil.c)
if(APPLE)
- foreach (os ${SANITIZER_COMMON_SUPPORTED_OS})
+ foreach (os osx)
add_compiler_rt_darwin_runtime(clang_rt.profile_${os} ${os}
STATIC
ARCHS ${PROFILE_SUPPORTED_ARCH}