summaryrefslogtreecommitdiff
path: root/lib/profile/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-03-20 03:23:10 +0000
committerDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-03-20 03:23:10 +0000
commit4709975bfe6b884e3b2b62da7545b01a82239906 (patch)
treec945165555e4835915952a1ccc892e8c350da07b /lib/profile/CMakeLists.txt
parentcab2b24e0704c4efb150c6ea44195b766e56a690 (diff)
PGO: Split out initialization of section bounds
Currently we register instrumentation data at runtime to determine the bounds of the sections where the data lives. Soon we'll implement platform-specific linker magic to determine this at link time. Move this logic to a separate file, so that our build system can choose the correct platform-specific code. No functionality change intended. <rdar://problem/15943240> git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@204299 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/profile/CMakeLists.txt')
-rw-r--r--lib/profile/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/profile/CMakeLists.txt b/lib/profile/CMakeLists.txt
index 20675372b..0374d6e7a 100644
--- a/lib/profile/CMakeLists.txt
+++ b/lib/profile/CMakeLists.txt
@@ -1,6 +1,7 @@
set(PROFILE_SOURCES
GCDAProfiling.c
InstrProfiling.c
+ InstrProfilingDefault.c
InstrProfilingExtras.c)
filter_available_targets(PROFILE_SUPPORTED_ARCH x86_64 i386 arm)