summaryrefslogtreecommitdiff
path: root/lib/profile/CMakeLists.txt
diff options
context:
space:
mode:
authorNathan Slingerland <slingn@gmail.com>2016-01-05 17:27:01 +0000
committerNathan Slingerland <slingn@gmail.com>2016-01-05 17:27:01 +0000
commit25d46471f24a19617939c79c2397eb7cda72f87f (patch)
tree82c2b5ccae1d43641c1e362459e4dbb46803e86c /lib/profile/CMakeLists.txt
parent3bbaf5d2bcda8f4f9181d8da9b9f5b5dd9675c43 (diff)
[PGO] Enable building compiler-rt profile support library on Windows
Summary: This change configures Windows builds to build the complier-rt profile support library (clang_rt.profile-i386.lib). Windows API incompatibilities in the compiler-rt profile lib are also fixed. Reviewers: davidxl, dnovillo Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D15830 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@256848 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/profile/CMakeLists.txt')
-rw-r--r--lib/profile/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/profile/CMakeLists.txt b/lib/profile/CMakeLists.txt
index 1b10ade0e..3f84c0e6d 100644
--- a/lib/profile/CMakeLists.txt
+++ b/lib/profile/CMakeLists.txt
@@ -35,7 +35,8 @@ set(PROFILE_SOURCES
InstrProfilingPlatformLinux.c
InstrProfilingPlatformOther.c
InstrProfilingRuntime.cc
- InstrProfilingUtil.c)
+ InstrProfilingUtil.c
+ WindowsMMap.c)
if(UNIX)
set(EXTRA_FLAGS