summaryrefslogtreecommitdiff
path: root/lib/profile/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2017-12-14 18:50:13 +0000
committerVedant Kumar <vsk@apple.com>2017-12-14 18:50:13 +0000
commit12e90365ed9cce1179df68586af3ec9d83bb0316 (patch)
tree0d0b59670b0515cd5f4bbe80c7753f6ef1f85305 /lib/profile/CMakeLists.txt
parentf6d0ce49a30c2b40d69369cd799f76f95c052b0e (diff)
Revert "(HEAD -> master, origin/master, origin/HEAD) [profile] Port the runtime to Solaris"
This reverts commit r320726. It looks like flock isn't available on Windows: http://lab.llvm.org:8011/builders/sanitizer-windows/builds/21317/steps/build%20compiler-rt/logs/stdio git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@320728 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/profile/CMakeLists.txt')
-rw-r--r--lib/profile/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/lib/profile/CMakeLists.txt b/lib/profile/CMakeLists.txt
index 91d67ec36..342f8ee7e 100644
--- a/lib/profile/CMakeLists.txt
+++ b/lib/profile/CMakeLists.txt
@@ -38,14 +38,6 @@ int main() {
" COMPILER_RT_TARGET_HAS_FCNTL_LCK)
-CHECK_CXX_SOURCE_COMPILES("
-#include <sys/utsname.h>
-int main() {
- return 0;
-}
-
-" COMPILER_RT_TARGET_HAS_UNAME)
-
add_compiler_rt_component(profile)
set(PROFILE_SOURCES
@@ -86,12 +78,6 @@ if(COMPILER_RT_TARGET_HAS_FCNTL_LCK)
-DCOMPILER_RT_HAS_FCNTL_LCK=1)
endif()
-if(COMPILER_RT_TARGET_HAS_UNAME)
- set(EXTRA_FLAGS
- ${EXTRA_FLAGS}
- -DCOMPILER_RT_HAS_UNAME=1)
-endif()
-
# This appears to be a C-only warning banning the use of locals in aggregate
# initializers. All other compilers accept this, though.
# nonstandard extension used : 'identifier' : cannot be initialized using address of automatic variable