summaryrefslogtreecommitdiff
path: root/lib/msan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-08-27 15:08:02 +0000
committerAlexey Samsonov <samsonov@google.com>2013-08-27 15:08:02 +0000
commite5fa243b20bf5e6a097bc58cbedfe6bed8a9b7d1 (patch)
tree44ec546168b34e749d09d3576ee21f598842a330 /lib/msan/CMakeLists.txt
parent0e38a67cd2d877e8680d65878c86c9e7e4fa4b1d (diff)
Properly generate lists of exported symbols for sanitizer runtimes
This change adds a Python script that is invoked for the just-built sanitizer runtime to generate the list of exported symbols passed to the linker. By default, it contains interceptors and sanitizer interface functions, but can be extended with tool-specific lists. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@189356 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/msan/CMakeLists.txt')
-rw-r--r--lib/msan/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/msan/CMakeLists.txt b/lib/msan/CMakeLists.txt
index b3e88ea29..98c296148 100644
--- a/lib/msan/CMakeLists.txt
+++ b/lib/msan/CMakeLists.txt
@@ -25,9 +25,10 @@ if(CAN_TARGET_${arch})
$<TARGET_OBJECTS:RTInterception.${arch}>
$<TARGET_OBJECTS:RTSanitizerCommon.${arch}>
$<TARGET_OBJECTS:RTSanitizerCommonLibc.${arch}>
- CFLAGS ${MSAN_RTL_CFLAGS}
- SYMS msan.syms)
- list(APPEND MSAN_RUNTIME_LIBRARIES clang_rt.msan-${arch})
+ CFLAGS ${MSAN_RTL_CFLAGS})
+ add_sanitizer_rt_symbols(clang_rt.msan-${arch} msan.syms.extra)
+ list(APPEND MSAN_RUNTIME_LIBRARIES clang_rt.msan-${arch}
+ clang_rt.msan-${arch}-symbols)
endif()
add_compiler_rt_resource_file(msan_blacklist msan_blacklist.txt)