summaryrefslogtreecommitdiff
path: root/lib/msan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-18 09:33:45 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-18 09:33:45 +0000
commitcbf39e036dd0af4d9cd4ea29b78d0428edc59b9c (patch)
treef1639a2ff7468773400b9eecfc02464eff10f224 /lib/msan/CMakeLists.txt
parent9257648ff0c17bc6c9d40295734b5afb6f6938a7 (diff)
[CMake] Add top-level target for each compiler-rt library, and add 'compiler-rt' target encompassing them all.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@201556 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/msan/CMakeLists.txt')
-rw-r--r--lib/msan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/msan/CMakeLists.txt b/lib/msan/CMakeLists.txt
index 2578b689c..76a122e94 100644
--- a/lib/msan/CMakeLists.txt
+++ b/lib/msan/CMakeLists.txt
@@ -35,6 +35,7 @@ endif()
add_compiler_rt_resource_file(msan_blacklist msan_blacklist.txt)
add_dependencies(msan msan_blacklist)
+add_dependencies(compiler-rt msan)
if(LLVM_INCLUDE_TESTS)
add_subdirectory(tests)