summaryrefslogtreecommitdiff
path: root/lib/msan/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2014-04-04 09:47:41 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2014-04-04 09:47:41 +0000
commitba4ad34df1af1c321da0981e1aaff9d35c45d37f (patch)
treee1d8ac67bf297961c9cf31724f7709c2380d507c /lib/msan/CMakeLists.txt
parent8dc0d7f875b37003ce805dfe04c88bee3f02a6b8 (diff)
[msan] Introduce MsanThread. Move thread-local allocator cache out of TLS.
This reduces .tbss from 109K down to almost nothing. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@205618 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/msan/CMakeLists.txt')
-rw-r--r--lib/msan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/msan/CMakeLists.txt b/lib/msan/CMakeLists.txt
index 7a5302606..a05d324fd 100644
--- a/lib/msan/CMakeLists.txt
+++ b/lib/msan/CMakeLists.txt
@@ -8,6 +8,7 @@ set(MSAN_RTL_SOURCES
msan_linux.cc
msan_new_delete.cc
msan_report.cc
+ msan_thread.cc
)
set(MSAN_RTL_CFLAGS ${SANITIZER_COMMON_CFLAGS})