summaryrefslogtreecommitdiff
path: root/lib/msan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-03-13 09:18:30 +0000
committerAlexey Samsonov <samsonov@google.com>2013-03-13 09:18:30 +0000
commita7e5db966299a50c0e68cf9d35e1130b6c024c94 (patch)
treea4ae33d158c9905625eb07c957013b8d1544ee06 /lib/msan/CMakeLists.txt
parent10fd3227546d17c7411241a45ebc143b2031c78d (diff)
[Sanitizer] Build ASan, TSan and MSan runtimes with -fno-rtti.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@176940 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/msan/CMakeLists.txt')
-rw-r--r--lib/msan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/msan/CMakeLists.txt b/lib/msan/CMakeLists.txt
index fa057a652..6f10942ce 100644
--- a/lib/msan/CMakeLists.txt
+++ b/lib/msan/CMakeLists.txt
@@ -11,6 +11,7 @@ set(MSAN_RTL_SOURCES
)
set(MSAN_RTL_CFLAGS
${SANITIZER_COMMON_CFLAGS}
+ -fno-rtti
-fPIE
# Prevent clang from generating libc calls.
-ffreestanding)