summaryrefslogtreecommitdiff
path: root/lib/msan/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Smith <richard-llvm@metafoo.co.uk>2013-03-23 00:31:07 +0000
committerRichard Smith <richard-llvm@metafoo.co.uk>2013-03-23 00:31:07 +0000
commita06fe9183fbffb78798a444da9bc3040fdd444aa (patch)
treed0891fc14db3ce813e10b7da7902eeff9bbc70cb /lib/msan/CMakeLists.txt
parenta05af3d0f2417cd6516460a46d0381a7345a5837 (diff)
Build and install .syms files alongside sanitizer runtimes. These are used to
specify which symbols are exported to DSOs when the sanitizer is statically linked into a binary. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@177784 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/msan/CMakeLists.txt')
-rw-r--r--lib/msan/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/msan/CMakeLists.txt b/lib/msan/CMakeLists.txt
index 6f10942ce..5eedbea74 100644
--- a/lib/msan/CMakeLists.txt
+++ b/lib/msan/CMakeLists.txt
@@ -24,7 +24,8 @@ if(CAN_TARGET_${arch})
SOURCES ${MSAN_RTL_SOURCES}
$<TARGET_OBJECTS:RTInterception.${arch}>
$<TARGET_OBJECTS:RTSanitizerCommon.${arch}>
- CFLAGS ${MSAN_RTL_CFLAGS})
+ CFLAGS ${MSAN_RTL_CFLAGS}
+ SYMS msan.syms)
list(APPEND MSAN_RUNTIME_LIBRARIES clang_rt.msan-${arch})
endif()