summaryrefslogtreecommitdiff
path: root/lib/lsan/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Matveev <earthdok@google.com>2013-05-23 12:58:56 +0000
committerSergey Matveev <earthdok@google.com>2013-05-23 12:58:56 +0000
commite850b87a9b18774385a337159c5ce1811bfc4a02 (patch)
tree632163784a77f9b72e552733f985a77f0ba9f721 /lib/lsan/CMakeLists.txt
parent3086d7bd6456e43b6695c8356db364ade826dce3 (diff)
[lsan] Add lit test support.
"check-lsan" now runs both the tests from lib/lsan/tests and any lit tests found under lib/lsan/lit_tests. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@182583 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/lsan/CMakeLists.txt')
-rw-r--r--lib/lsan/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/lsan/CMakeLists.txt b/lib/lsan/CMakeLists.txt
index beb9c8aa4..378f08199 100644
--- a/lib/lsan/CMakeLists.txt
+++ b/lib/lsan/CMakeLists.txt
@@ -45,4 +45,7 @@ if (NOT APPLE AND NOT ANDROID)
endforeach()
endif()
-add_subdirectory(tests)
+if (LLVM_INCLUDE_TESTS)
+ add_subdirectory(tests)
+endif()
+add_subdirectory(lit_tests)