summaryrefslogtreecommitdiff
path: root/lib/lsan/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Ricci <francisjricci@gmail.com>2017-06-19 14:09:10 +0000
committerFrancis Ricci <francisjricci@gmail.com>2017-06-19 14:09:10 +0000
commita3d787dff9cc28412a3df4035e23edba6ddf5357 (patch)
tree365c3e1d4ce74e50c23702c4164785d240b7d220 /lib/lsan/CMakeLists.txt
parent80ed4944ba672f0f7a2143f149b59e833b94d2f6 (diff)
Add lsan interceptors for libdispatch functions on darwin
Summary: This is required for standalone LSan to work with libdispatch worker threads, and is a slimmed down version of the functionality provided for ASan in asan_mac.cc. Reviewers: alekseyshl, kubamracek, glider, kcc Subscribers: mgorny, llvm-commits Differential Revision: https://reviews.llvm.org/D34247 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@305695 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/lsan/CMakeLists.txt')
-rw-r--r--lib/lsan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/lsan/CMakeLists.txt b/lib/lsan/CMakeLists.txt
index 55c825f5c..bd3a96f32 100644
--- a/lib/lsan/CMakeLists.txt
+++ b/lib/lsan/CMakeLists.txt
@@ -13,6 +13,7 @@ set(LSAN_SOURCES
lsan_allocator.cc
lsan_linux.cc
lsan_interceptors.cc
+ lsan_mac.cc
lsan_malloc_mac.cc
lsan_preinit.cc
lsan_thread.cc)