summaryrefslogtreecommitdiff
path: root/lib/lsan/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Matveev <earthdok@google.com>2013-08-22 13:23:22 +0000
committerSergey Matveev <earthdok@google.com>2013-08-22 13:23:22 +0000
commit34fe7e14ee64a3f2768c8a0e789cba607fd69867 (patch)
treece1b2c6003ea424c81f96a2ee910391e0ae5790c /lib/lsan/CMakeLists.txt
parent0d77f8cb7b8feeb10ea00f2ec64ed300fde260fe (diff)
[lsan] Build standalone LSan with -fno-rtti.
Fix issue where C code could not be built with -fsanitize=leak. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@189010 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/lsan/CMakeLists.txt')
-rw-r--r--lib/lsan/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/lsan/CMakeLists.txt b/lib/lsan/CMakeLists.txt
index d85f14426..b91b675d8 100644
--- a/lib/lsan/CMakeLists.txt
+++ b/lib/lsan/CMakeLists.txt
@@ -1,7 +1,8 @@
include_directories(..)
set(LSAN_CFLAGS
- ${SANITIZER_COMMON_CFLAGS})
+ ${SANITIZER_COMMON_CFLAGS}
+ -fno-rtti)
set(LSAN_COMMON_SOURCES
lsan_common.cc