summaryrefslogtreecommitdiff
path: root/lib/interception/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2012-09-11 11:55:45 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2012-09-11 11:55:45 +0000
commit34fc56c43f60be0b85a0e3ce30658fd98951f0b8 (patch)
treef4737661cd3d631d5ee616f03854deecd063425e /lib/interception/CMakeLists.txt
parent7e72e45e3b725ef29b82fd4386c6571d64f9b6cc (diff)
CMake build rules for ASan Android runtime and tests.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@163613 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/interception/CMakeLists.txt')
-rw-r--r--lib/interception/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/interception/CMakeLists.txt b/lib/interception/CMakeLists.txt
index 2c7619b68..00a3e8bf1 100644
--- a/lib/interception/CMakeLists.txt
+++ b/lib/interception/CMakeLists.txt
@@ -34,9 +34,9 @@ else()
set_target_compile_flags(RTInterception.i386
${INTERCEPTION_CFLAGS} ${TARGET_I386_CFLAGS})
endif()
- if(CAN_TARGET_ARM_ANDROID)
+ if(ANDROID)
add_library(RTInterception.arm.android OBJECT ${INTERCEPTION_SOURCES})
set_target_compile_flags(RTInterception.arm.android
- ${INTERCEPTION_CFLAGS} ${TARGET_ARM_ANDROID_CFLAGS})
+ ${INTERCEPTION_CFLAGS})
endif()
endif()