summaryrefslogtreecommitdiff
path: root/lib/hwasan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Shlyapnikov <alekseys@google.com>2018-04-23 18:19:23 +0000
committerAlex Shlyapnikov <alekseys@google.com>2018-04-23 18:19:23 +0000
commit82b5b2542b598d9182d724609101e2cd5420ed13 (patch)
tree7f9b0c0fb73a547503e7a55fb6578639dc25fd8d /lib/hwasan/CMakeLists.txt
parent0ab84bd8d3ee0935bb5368f7db51957106c3b654 (diff)
[HWASan] Introduce non-zero based and dynamic shadow memory (compiler-rt).
Retire the fixed shadow memory mapping to avoid conflicts with default process memory mapping (currently manifests on Android). Tests on AArch64 show <1% performance loss and code size increase, making it possible to use dynamic shadow memory by default. Keep the fixed shadow memory mapping around to be able to run performance comparison tests later. Re-commiting D45847 with fixed shadow for x86-64. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@330624 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/hwasan/CMakeLists.txt')
-rw-r--r--lib/hwasan/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/hwasan/CMakeLists.txt b/lib/hwasan/CMakeLists.txt
index 88a1e8c53..a808d9e23 100644
--- a/lib/hwasan/CMakeLists.txt
+++ b/lib/hwasan/CMakeLists.txt
@@ -4,11 +4,12 @@ include_directories(..)
set(HWASAN_RTL_SOURCES
hwasan.cc
hwasan_allocator.cc
+ hwasan_dynamic_shadow.cc
hwasan_interceptors.cc
hwasan_linux.cc
+ hwasan_poisoning.cc
hwasan_report.cc
hwasan_thread.cc
- hwasan_poisoning.cc
)
set(HWASAN_RTL_CXX_SOURCES