summaryrefslogtreecommitdiff
path: root/lib/fuzzer/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Morehouse <mascasa@google.com>2017-12-08 22:54:44 +0000
committerMatt Morehouse <mascasa@google.com>2017-12-08 22:54:44 +0000
commitba895ecaa3174f0c20468867e37dbf7210026d98 (patch)
tree83941276f39f501e11a8727f2580b25f0d6c9fe1 /lib/fuzzer/CMakeLists.txt
parent741ec2c3c00cd768151fc4cfc37d4e4d43c9f58b (diff)
[libFuzzer] Add support for Fuchsia OS.
Summary: This patch adds the initial support for Fuchsia. - LIBFUZZER_FUCHSIA is added as an OS type in FuzzerDefs.h - Fuchsia is, by design, not POSIX compliant. However, it does use ELF and supports common POSIX I/O functions. Thus, FuzzerExtFunctions.h and FuzzerIO.h are implemented by extending the header guards in FuzzerExtFunctionsWeak.cpp and FuzzerIOPosix.cpp to include LIBFUZZER_FUCHSIA. - The platform-specific portions of FuzzerUtil.h are implemented by FuzzerUtilFuchsia.cpp, which makes use of exception ports, syscalls, and the launchpad library. - The experimental equivalence server is not currently supported, so FuzzerShmem.h is implemented by stub methods in FuzzerShmemFuchsia.cpp. Any future implementation will likely involve VMOs. Tested with ASAN/SanCov on Fuchsia/x86-64 with the canonical toy fuzzer. Patch By: aarongreen Reviewers: kcc, morehouse, flowerhack, phosek Reviewed By: kcc, phosek, Eugene.Zelenko Subscribers: srhines, mgorny, Eugene.Zelenko Differential Revision: https://reviews.llvm.org/D40974 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@320210 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/fuzzer/CMakeLists.txt')
-rw-r--r--lib/fuzzer/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/fuzzer/CMakeLists.txt b/lib/fuzzer/CMakeLists.txt
index e442b645e..9769be52a 100644
--- a/lib/fuzzer/CMakeLists.txt
+++ b/lib/fuzzer/CMakeLists.txt
@@ -18,6 +18,7 @@ set(LIBFUZZER_SOURCES
FuzzerTracePC.cpp
FuzzerUtil.cpp
FuzzerUtilDarwin.cpp
+ FuzzerUtilFuchsia.cpp
FuzzerUtilLinux.cpp
FuzzerUtilPosix.cpp
FuzzerUtilWindows.cpp