summaryrefslogtreecommitdiff
path: root/lib/esan/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Bruening <bruening@google.com>2016-06-03 16:14:07 +0000
committerDerek Bruening <bruening@google.com>2016-06-03 16:14:07 +0000
commitd5bcae95c1d1b013893bd3ca6cc04e7f7f5d5736 (patch)
tree97124f984e3e8aa833e4960444193770683a4730 /lib/esan/CMakeLists.txt
parent031c1e40660c8eaaa418ce84b16b82b37ca32652 (diff)
[esan] Add sideline itimer support
Summary: Adds support for creating a separate thread for performing "sideline" actions on a periodic basis via an itimer. A new class SidelineThread implements this feature, exposing a sampling callback to the caller. Adds initial usage of sideline sampling to the working set tool. For now it simply prints the usage at each snapshot at verbosity level 1. Adds a test of this behavior. Adds a new option -record_snapshots to control whether we sample and a new option -sample_freq to control the periodicity of the sampling. Reviewers: aizatsky Subscribers: vitalybuka, zhaoqin, kcc, eugenis, llvm-commits, kubabrecka Differential Revision: http://reviews.llvm.org/D20751 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@271682 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/esan/CMakeLists.txt')
-rw-r--r--lib/esan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/esan/CMakeLists.txt b/lib/esan/CMakeLists.txt
index ac994d949..573d7d456 100644
--- a/lib/esan/CMakeLists.txt
+++ b/lib/esan/CMakeLists.txt
@@ -13,6 +13,7 @@ set(ESAN_SOURCES
esan_interface.cpp
esan_interceptors.cpp
esan_linux.cpp
+ esan_sideline_linux.cpp
cache_frag.cpp
working_set.cpp
working_set_posix.cpp)