summaryrefslogtreecommitdiff
path: root/lib/esan/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Bruening <bruening@google.com>2016-05-28 00:25:16 +0000
committerDerek Bruening <bruening@google.com>2016-05-28 00:25:16 +0000
commit929d23ef5045d955ef2c36f2bbdb3dc61eca518f (patch)
treef8cfee7f2203e66ac336b4b63e2958179b840c99 /lib/esan/CMakeLists.txt
parenteaa4331bc17ed21cc69dcca50bc6ebf66bdaceb6 (diff)
[esan] Add handling of large stack size rlimits
Summary: Adds detection of large stack size rlimits (over 1 TB or unlimited), which results in an mmap location that our shadow mapping does not support. We re-exec the application in this situation. Adds a test of this behavior. Adds general detection of mmap regions outside of our app regions. In the future we want to try to adaptively handle these but for now we abort. Moves the existing Linux-specific mmap code into a platform-specific file where the new rlimit code lives. Reviewers: eugenis Subscribers: vitalybuka, zhaoqin, kcc, aizatsky, llvm-commits, kubabrecka Differential Revision: http://reviews.llvm.org/D20745 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@271079 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/esan/CMakeLists.txt')
-rw-r--r--lib/esan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/esan/CMakeLists.txt b/lib/esan/CMakeLists.txt
index 3bdf32b72..24bed26a2 100644
--- a/lib/esan/CMakeLists.txt
+++ b/lib/esan/CMakeLists.txt
@@ -12,6 +12,7 @@ set(ESAN_SOURCES
esan_flags.cpp
esan_interface.cpp
esan_interceptors.cpp
+ esan_linux.cpp
cache_frag.cpp
working_set.cpp)