summaryrefslogtreecommitdiff
path: root/lib/esan/CMakeLists.txt
diff options
context:
space:
mode:
authorQin Zhao <zhaoqin@google.com>2016-05-25 17:49:00 +0000
committerQin Zhao <zhaoqin@google.com>2016-05-25 17:49:00 +0000
commita9494465352c28ce019b9e8ea8ae0eeb6ca03176 (patch)
tree9e6cf47c137a8a23f38a8c0e31d033469c1d2c4f /lib/esan/CMakeLists.txt
parent4502401cf8de82c0e2a12aa8fe6971b0d6e56121 (diff)
[esan][cfrag] Add skeleton for cache fragmentation tool support
Summary: Adds cache_frag.h and cache_frag.cpp for the cache fragmentation tool. Updates test struct-simple.cpp. Reviewers: aizatsky Subscribers: filcab, zhaoqin, llvm-commits, eugenis, vitalybuka, kcc, bruening, kubabrecka Differential Revision: http://reviews.llvm.org/D20538 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@270737 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/esan/CMakeLists.txt')
-rw-r--r--lib/esan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/esan/CMakeLists.txt b/lib/esan/CMakeLists.txt
index 029c13579..3bdf32b72 100644
--- a/lib/esan/CMakeLists.txt
+++ b/lib/esan/CMakeLists.txt
@@ -12,6 +12,7 @@ set(ESAN_SOURCES
esan_flags.cpp
esan_interface.cpp
esan_interceptors.cpp
+ cache_frag.cpp
working_set.cpp)
foreach (arch ${ESAN_SUPPORTED_ARCH})