summaryrefslogtreecommitdiff
path: root/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Golin <renato.golin@linaro.org>2014-07-22 20:59:38 +0000
committerRenato Golin <renato.golin@linaro.org>2014-07-22 20:59:38 +0000
commitad18d609f6c6ef413f8930ce3fb7d91bf5d39d62 (patch)
tree46d826a578808a69b0110a88483154703584498b /lib/builtins/CMakeLists.txt
parentd43d2eca16246d7d24b5dd2ed5fbe5cdbeca3c73 (diff)
Include assembly files in builtins library build
The CMake assembler build system ignores the .S assembly files in builtins library build. This patch fixes the issue. Patch by: Sumanth Gundapaneni git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@213684 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/builtins/CMakeLists.txt')
-rw-r--r--lib/builtins/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/builtins/CMakeLists.txt b/lib/builtins/CMakeLists.txt
index 054ff59b2..6289cdd18 100644
--- a/lib/builtins/CMakeLists.txt
+++ b/lib/builtins/CMakeLists.txt
@@ -251,6 +251,7 @@ add_custom_target(builtins)
if (NOT WIN32)
foreach(arch x86_64 i386 arm)
if(CAN_TARGET_${arch})
+ set_source_files_properties(${${arch}_SOURCES} PROPERTIES LANGUAGE C)
add_compiler_rt_runtime(clang_rt.builtins-${arch} ${arch} STATIC
SOURCES ${${arch}_SOURCES}
CFLAGS "-std=c99")