summaryrefslogtreecommitdiff
path: root/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2014-07-26 04:04:02 +0000
committerSaleem Abdulrasool <compnerd@compnerd.org>2014-07-26 04:04:02 +0000
commit1f5b48b9fa31ab95c3916a4f81f3a91916efd09c (patch)
tree884b7b14b5752496cf9ef5644188fb923ff637e5 /lib/builtins/CMakeLists.txt
parent90b88645985e9d5df5e184d46f0737ebcfe95999 (diff)
builtins: re-enable building assembly sources
Re-apply SVN r213684 which was reverted in SVN r213724 since it broke the build bots. Add a tweak to enable inclusion of the assembly sources in standalone build as well. Original commit message: This patch address the PR20360. The CMake assembler build system ignores the .S assembly files in builtins library build. This patch fixes the issue. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@214013 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/builtins/CMakeLists.txt')
-rw-r--r--lib/builtins/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/builtins/CMakeLists.txt b/lib/builtins/CMakeLists.txt
index 054ff59b2..6289cdd18 100644
--- a/lib/builtins/CMakeLists.txt
+++ b/lib/builtins/CMakeLists.txt
@@ -251,6 +251,7 @@ add_custom_target(builtins)
if (NOT WIN32)
foreach(arch x86_64 i386 arm)
if(CAN_TARGET_${arch})
+ set_source_files_properties(${${arch}_SOURCES} PROPERTIES LANGUAGE C)
add_compiler_rt_runtime(clang_rt.builtins-${arch} ${arch} STATIC
SOURCES ${${arch}_SOURCES}
CFLAGS "-std=c99")