summaryrefslogtreecommitdiff
path: root/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Golin <renato.golin@linaro.org>2014-07-23 04:46:23 +0000
committerRenato Golin <renato.golin@linaro.org>2014-07-23 04:46:23 +0000
commit01a753c9b96979d60e5ec35e3d768d8f9b052261 (patch)
treefaad3b4cee8eeb1689c904f57cc3117c9a46c59e /lib/builtins/CMakeLists.txt
parent8df29ffdf6e4c08c21afbf15f4798ba0fab83667 (diff)
Revert "Include assembly files in builtins library build"
This reverts commit r213684, since it was breaking the compiler-rt build and the sanitizers' bot. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@213724 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/builtins/CMakeLists.txt')
-rw-r--r--lib/builtins/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/builtins/CMakeLists.txt b/lib/builtins/CMakeLists.txt
index 6289cdd18..054ff59b2 100644
--- a/lib/builtins/CMakeLists.txt
+++ b/lib/builtins/CMakeLists.txt
@@ -251,7 +251,6 @@ add_custom_target(builtins)
if (NOT WIN32)
foreach(arch x86_64 i386 arm)
if(CAN_TARGET_${arch})
- set_source_files_properties(${${arch}_SOURCES} PROPERTIES LANGUAGE C)
add_compiler_rt_runtime(clang_rt.builtins-${arch} ${arch} STATIC
SOURCES ${${arch}_SOURCES}
CFLAGS "-std=c99")