summaryrefslogtreecommitdiff
path: root/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorWeiming Zhao <weimingz@codeaurora.org>2017-01-21 18:24:55 +0000
committerWeiming Zhao <weimingz@codeaurora.org>2017-01-21 18:24:55 +0000
commitfd90db7e2b950ccfed1d96d71ae4a043b3c29b58 (patch)
tree5a9e20798c58ea98bb9fff3ee2900e34809e8e39 /lib/builtins/CMakeLists.txt
parentb69e84dee887092596a6b9037b7ae71a5c4879ad (diff)
[Bultin][ARM] Make aeabi_memset be Thumb1 compatible and other asm
syntax fix Summary: Make the asm of aeabi_memset be assembled for thumb1. Also fix some instructions to conform with the syntax of ARM reference manual. For example, muls requires the form of "Rd, Rn, Rd" and orrs requires the form of "Rd, Rm". Clang-as is benign but it may fail other assembler if not in the exact form. Reviewers: rengolin, compnerd, kubamracek Reviewed By: rengolin, compnerd Subscribers: aemerson, llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D28971 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@292727 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/builtins/CMakeLists.txt')
-rw-r--r--lib/builtins/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/builtins/CMakeLists.txt b/lib/builtins/CMakeLists.txt
index 775dafe89..2649c08fe 100644
--- a/lib/builtins/CMakeLists.txt
+++ b/lib/builtins/CMakeLists.txt
@@ -337,6 +337,7 @@ set(thumb1_EABI_SOURCES
arm/aeabi_idivmod.S
arm/aeabi_memcmp.S
arm/aeabi_memcpy.S
+ arm/aeabi_memset.S
arm/aeabi_memmove.S
arm/aeabi_uidivmod.S)