summaryrefslogtreecommitdiff
path: root/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2016-11-29 02:31:40 +0000
committerSaleem Abdulrasool <compnerd@compnerd.org>2016-11-29 02:31:40 +0000
commitc6c13e588d2abb9ad29992bd0273c3a7727fe2ca (patch)
treeb987668890bf2add4df2bb84beb39baaee91e34c /lib/builtins/CMakeLists.txt
parent9eaa3ef462b338fa2426930e2d3072b43291abcf (diff)
builtins: switch to c11 from c99
This fixes an incorrect standard usage of GNU99 when the compiler check was for the ISO standard C99. Furthermore, bump the dependency up to C11. The motivation for this change is ARM EHABI compatibility with clang 3.8. We rely on a type definition redefinition which causes an error with -Werror builds. This is problematic for FreeBSD builds. Switching to C11 allows the compatibility without the unnecessary pedantic warning. The alternative would be to clutter the support header with a `pragma clang diagnostic ignore`. GCC 4.8+ and the supported clang revisions along with MSVC support enough of C11 to allow building the builtins in C11 mode. No functional change intended. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@288099 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/builtins/CMakeLists.txt')
-rw-r--r--lib/builtins/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/builtins/CMakeLists.txt b/lib/builtins/CMakeLists.txt
index 64d5ca3d4..ff023dafa 100644
--- a/lib/builtins/CMakeLists.txt
+++ b/lib/builtins/CMakeLists.txt
@@ -451,7 +451,7 @@ if (APPLE)
else ()
set(BUILTIN_CFLAGS "")
- append_list_if(COMPILER_RT_HAS_STD_C99_FLAG -std=gnu99 BUILTIN_CFLAGS)
+ append_list_if(COMPILER_RT_HAS_STD_C11_FLAG -std=c11 BUILTIN_CFLAGS)
# These flags would normally be added to CMAKE_C_FLAGS by the llvm
# cmake step. Add them manually if this is a standalone build.