summaryrefslogtreecommitdiff
path: root/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-07-25 20:25:38 +0000
committerChris Bieneman <beanz@apple.com>2016-07-25 20:25:38 +0000
commit5d5ea7d104cb3ca5545b3d7eb1822b65c0671332 (patch)
tree54b787c8440b574acc3e6e5206123505df3788e4 /lib/builtins/CMakeLists.txt
parentbb6c145b44d2a1d29d365770ddab0f4eade8f47e (diff)
Revert "Enable cross-compilation across architectures on android"
This reverts commit r276333. As I commented in the review (https://reviews.llvm.org/D22415), this change isn't needed because CMAKE_C_FLAGS is implicitly added by CMake to the command line for all C source files. With this patch enabled CMAKE_C_FLAGS is duplicated on all C sources, and applied to ASM sources, which is not ideal. I sent an email about this to llvm-commits on the commit thread. I suspect the problem the patch author was actually seeing is that CMAKE_C_FLAGS isn't applied to ASM files, and the builtins library has quite a few of those. The correct solution there is to specify CMAKE_ASM_FLAGS with whatever flags need to be passed to the compiler when compiling ASM files. If there are other problems with flag propagation, please let me know. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@276683 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/builtins/CMakeLists.txt')
-rw-r--r--lib/builtins/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/builtins/CMakeLists.txt b/lib/builtins/CMakeLists.txt
index 274b0b4e3..d5a1efe79 100644
--- a/lib/builtins/CMakeLists.txt
+++ b/lib/builtins/CMakeLists.txt
@@ -413,7 +413,7 @@ else ()
STATIC
ARCHS ${arch}
SOURCES ${${arch}_SOURCES}
- CFLAGS ${maybe_stdc99} ${CMAKE_C_FLAGS}
+ CFLAGS ${maybe_stdc99}
PARENT_TARGET builtins)
endif ()
endforeach ()