summaryrefslogtreecommitdiff
path: root/lib/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2016-12-01 22:00:54 +0000
committerSaleem Abdulrasool <compnerd@compnerd.org>2016-12-01 22:00:54 +0000
commit300bd34553a986d543c57bcead2ba14cc1cb7a82 (patch)
tree0843f8ddcdd7e7d2afaa3b2285dff8443a8cf2f6 /lib/builtins/CMakeLists.txt
parentd2e59ebfdaa0a5c9ed5a5324889b25172ce1e97a (diff)
build: fix building for Windows after SVN r287465
The previous change for enabling MinGW did not preserve the Win32 check and added the EABI specific routines to a Windows build which does not use the EABI routines. Correct the conditional check for that. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@288422 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/builtins/CMakeLists.txt')
-rw-r--r--lib/builtins/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/builtins/CMakeLists.txt b/lib/builtins/CMakeLists.txt
index ff023dafa..b33786a85 100644
--- a/lib/builtins/CMakeLists.txt
+++ b/lib/builtins/CMakeLists.txt
@@ -395,7 +395,7 @@ if(MINGW)
udivmodsi4.c
udivsi3.c
umoddi3.c)
-else(MINGW)
+elseif(NOT WIN32)
# TODO the EABI sources should only be added to EABI targets
set(arm_SOURCES
${arm_SOURCES}