summaryrefslogtreecommitdiff
path: root/lib/asan/CMakeLists.txt
diff options
context:
space:
mode:
authorFilipe Cabecinhas <me@filcab.net>2016-08-15 19:30:21 +0000
committerFilipe Cabecinhas <me@filcab.net>2016-08-15 19:30:21 +0000
commit6682359e4a65e5eb8a6157e36f90b9410bf3f21e (patch)
tree129f1329797329a880670073648d0ed900457b54 /lib/asan/CMakeLists.txt
parent96ebe14bf1b7977bd2d87741687968560f20c9e9 (diff)
Split DescribeAddressIfShadow between a function that gets all the information, and one that prints it.
Summary: Replacement for part of D23518 This is the first patch to start reifying information about errors. It deals only with reifying shadow address-related information. It will allow us to generate structures with all the relevant information for a given error so a debugger can get to them or they can be included in a core dump. Reviewers: kcc, samsonov Subscribers: kubabrecka, llvm-commits Differential Revision: https://reviews.llvm.org/D23519 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@278718 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/asan/CMakeLists.txt')
-rw-r--r--lib/asan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/asan/CMakeLists.txt b/lib/asan/CMakeLists.txt
index b7e41fc70..7325932f0 100644
--- a/lib/asan/CMakeLists.txt
+++ b/lib/asan/CMakeLists.txt
@@ -4,6 +4,7 @@ set(ASAN_SOURCES
asan_allocator.cc
asan_activation.cc
asan_debugging.cc
+ asan_descriptions.cc
asan_fake_stack.cc
asan_flags.cc
asan_globals.cc