summaryrefslogtreecommitdiff
path: root/lib/asan/CMakeLists.txt
diff options
context:
space:
mode:
authorFilipe Cabecinhas <me@filcab.net>2016-08-30 17:08:55 +0000
committerFilipe Cabecinhas <me@filcab.net>2016-08-30 17:08:55 +0000
commit43044ab0d65bccde7cd7f8377fe31a52dd3388f1 (patch)
treeb6fdfdaa34286d9b295f6f37ece09ee128521b5d /lib/asan/CMakeLists.txt
parent9444a2395b8c807189b39585ce0a0ccea70b32f3 (diff)
Start reifying error descriptions (Re-do of D23672 supporting VS2013)
Summary: @kcc: I know you've accepted the other revision, but since this is a non-trivial change, I'm updating it to show why D24029 would help. This commit sets up the infrastructure to use reified error descriptions, and moves ReportStackOverflow to the new system. After we convert all the errors, we'll be able to simplify ScopedInErrorReport and remove the older debugging mechanism which had some errors partly reified in some way. We'll be able to maintain the external API. ScopedInErrorReport will be able to track one of the reified errors at a time. The purpose of this is so we have its destructor actually print the error and possibly interface with the debugger (will depend on the platform, of course). Reviewers: kcc, samsonov, timurrrr Subscribers: kcc, llvm-commits, kubabrecka Differential Revision: https://reviews.llvm.org/D24030 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@280111 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/asan/CMakeLists.txt')
-rw-r--r--lib/asan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/asan/CMakeLists.txt b/lib/asan/CMakeLists.txt
index be274df2a..e37705e0d 100644
--- a/lib/asan/CMakeLists.txt
+++ b/lib/asan/CMakeLists.txt
@@ -5,6 +5,7 @@ set(ASAN_SOURCES
asan_activation.cc
asan_debugging.cc
asan_descriptions.cc
+ asan_errors.cc
asan_fake_stack.cc
asan_flags.cc
asan_globals.cc