summaryrefslogtreecommitdiff
path: root/lib/asan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Shlyapnikov <alekseys@google.com>2017-07-20 01:29:01 +0000
committerAlex Shlyapnikov <alekseys@google.com>2017-07-20 01:29:01 +0000
commit3a390dc512db0f74e9875546d9b7c4093fcb07b5 (patch)
tree8a00d28d7165713ade56f79ea1770d0474a50fdb /lib/asan/CMakeLists.txt
parent6553f3f19ef0f5bdcdde8f4ffc6303da06087e81 (diff)
[asan] Move memcpy, memmove, memset code out of asan_interceptors.cc
This is a pure refactoring change. It simply moves all the code and macros related to defining the ASan interceptor versions of memcpy, memmove, and memset into a separate file. This makes it cleaner to disable all the other interceptor code while still using these three, for a port that defines these but not the other common interceptors. Reviewers: alekseyshl Subscribers: llvm-commits Differential Revision: https://reviews.llvm.org/D35590 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@308575 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/asan/CMakeLists.txt')
-rw-r--r--lib/asan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/asan/CMakeLists.txt b/lib/asan/CMakeLists.txt
index a2d4630df..47afa79bd 100644
--- a/lib/asan/CMakeLists.txt
+++ b/lib/asan/CMakeLists.txt
@@ -11,6 +11,7 @@ set(ASAN_SOURCES
asan_globals.cc
asan_globals_win.cc
asan_interceptors.cc
+ asan_interceptors_memintrinsics.cc
asan_linux.cc
asan_mac.cc
asan_malloc_linux.cc