summaryrefslogtreecommitdiff
path: root/lib/asan/CMakeLists.txt
diff options
context:
space:
mode:
authorTimur Iskhodzhanov <timurrrr@google.com>2014-08-25 16:45:53 +0000
committerTimur Iskhodzhanov <timurrrr@google.com>2014-08-25 16:45:53 +0000
commit2b4c5e056d6ab3e8b2a0d94f25096ec1b7ecee3b (patch)
tree41acf20f95baf9c84d3e2b47eaac6aebabc1eaf1 /lib/asan/CMakeLists.txt
parent305ee68374b9e8912843f4e8a4b6c78c8921d1c8 (diff)
[ASan/Win] Add /DEBUG to the MD RTL link flags
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@216387 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/asan/CMakeLists.txt')
-rw-r--r--lib/asan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/asan/CMakeLists.txt b/lib/asan/CMakeLists.txt
index 56d5ed6c4..a304ff1ed 100644
--- a/lib/asan/CMakeLists.txt
+++ b/lib/asan/CMakeLists.txt
@@ -58,6 +58,7 @@ append_if(WIN32 INTERCEPTION_DYNAMIC_CRT ASAN_DYNAMIC_DEFINITIONS)
set(ASAN_DYNAMIC_CFLAGS ${ASAN_CFLAGS})
append_if(COMPILER_RT_HAS_FTLS_MODEL_INITIAL_EXEC
-ftls-model=initial-exec ASAN_DYNAMIC_CFLAGS)
+append_if(MSVC /DEBUG ASAN_DYNAMIC_CFLAGS)
append_if(COMPILER_RT_HAS_LIBC c ASAN_DYNAMIC_LIBS)
append_if(COMPILER_RT_HAS_LIBDL dl ASAN_DYNAMIC_LIBS)