summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Potapenko <glider@google.com>2012-08-24 07:49:22 +0000
committerAlexander Potapenko <glider@google.com>2012-08-24 07:49:22 +0000
commit1e2525d0ec9ac64e583b57316ea30cecce591fb1 (patch)
treef2a2ed8e522aa40771fe6bd8595f18e22537a23f /lib/CMakeLists.txt
parentffad0c4bc88056f5c9360af792ef2e6c1e8259bf (diff)
Add add_clang_runtime_shared_library() CMake function and use it to put the shared ASan runtime in the appropriate place.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@162546 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 72ab9b470..4961e2d0c 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -19,6 +19,10 @@ function(add_clang_runtime_static_library)
set_target_properties(${ARGN} PROPERTIES
ARCHIVE_OUTPUT_DIRECTORY ${CLANG_RUNTIME_LIB_DIR})
endfunction()
+function(add_clang_runtime_shared_library)
+ set_target_properties(${ARGN} PROPERTIES
+ LIBRARY_OUTPUT_DIRECTORY ${CLANG_RUNTIME_LIB_DIR})
+endfunction()
# First, add the subdirectories which contain feature-based runtime libraries
# and several convenience helper libraries.