summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Vyukov <dvyukov@google.com>2014-03-03 13:15:12 +0000
committerDmitry Vyukov <dvyukov@google.com>2014-03-03 13:15:12 +0000
commitfce1ac5069f9cff3605f8c7b0203bac7bf580fd5 (patch)
tree28442e88ce80355bb8d31b17bcd01ca3d4f7f174 /lib/CMakeLists.txt
parenteee9f5a897cefdd00b7d5da34f332f9721144c53 (diff)
tsan: replace deadlock detector custom build script with cmake file
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@202708 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 1c189c2bc..f033e3668 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -29,6 +29,7 @@ if(NOT LLVM_USE_SANITIZER)
if(CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT ANDROID)
# ThreadSanitizer and MemorySanitizer are supported on Linux only.
add_subdirectory(tsan)
+ add_subdirectory(tsan/dd)
add_subdirectory(msan)
add_subdirectory(msandr)
add_subdirectory(dfsan)