summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-20 13:14:05 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-20 13:14:05 +0000
commitfc10971680641fdfe828aca3065bd591f71ead3e (patch)
treef677c67b82ca6249d80c927952d54da053d57611 /lib/CMakeLists.txt
parente6699c4832464106d60fcb9c1da5a645cc6c3839 (diff)
[FreeBSD] Enable building a few runtime libraries on FreeBSD.
Patch by Viktor Kutuzov! git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@201783 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 1c189c2bc..6faf88160 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -6,8 +6,9 @@ include(SanitizerUtils)
# Don't build sanitizers in the bootstrap build.
if(NOT LLVM_USE_SANITIZER)
# AddressSanitizer is supported on Linux and Mac OS X.
+ # FreeBSD port is work-in-progress.
# 32-bit Windows support is experimental.
- if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux")
+ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD")
set(SUPPORTS_BUILDING_ASAN TRUE)
elseif(CMAKE_SYSTEM_NAME MATCHES "Windows"
AND MSVC AND CMAKE_SIZEOF_VOID_P EQUAL 4)
@@ -20,8 +21,9 @@ if(NOT LLVM_USE_SANITIZER)
add_subdirectory(interception)
add_subdirectory(sanitizer_common)
endif()
- if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux" AND NOT ANDROID)
+ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD" AND NOT ANDROID)
# LSan, UBsan and profile can be built on Mac OS and Linux.
+ # FreeBSD port is work-in-progress.
add_subdirectory(lsan)
add_subdirectory(profile)
add_subdirectory(ubsan)