summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2015-07-02 01:44:34 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2015-07-02 01:44:34 +0000
commitf78932b4e5699c8a68be72c928c60e0336edf6ea (patch)
treee35e92c52c4496664dcd0054f43183873de9d3ba /lib/CMakeLists.txt
parent5e8af5dbfb9d7d043cf39a7d4e49a45e8c4d1569 (diff)
Re-apply r241217 with build fixes:
- Disable building of the interceptor library on 64-bit Windows. - Mangle names in /alternatename directive for 32-bit Windows. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@241224 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 3a5d4297e..009c59f4d 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -4,8 +4,11 @@
include(AddCompilerRT)
include(SanitizerUtils)
-if(COMPILER_RT_HAS_SANITIZER_COMMON)
+if(COMPILER_RT_HAS_INTERCEPTION)
add_subdirectory(interception)
+endif()
+
+if(COMPILER_RT_HAS_SANITIZER_COMMON)
add_subdirectory(sanitizer_common)
add_subdirectory(lsan)
add_subdirectory(ubsan)