summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2015-09-29 21:43:37 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2015-09-29 21:43:37 +0000
commitef066200d420b27069fd793835c8927ed1eb5563 (patch)
treef2894ec13dccc7f0e7dfacabc919383160b28eb7 /lib/CMakeLists.txt
parent89fbf48c3f234712be522e62591a9cb137adb69d (diff)
[CFI] Make CFI tests require UBSan (for diagnostic mode).
CFI itself, on the other hand, doesn't require anything, including sanitizer_common. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@248830 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index fb5851aae..9215b080b 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -15,11 +15,12 @@ if(COMPILER_RT_BUILD_SANITIZERS)
if(COMPILER_RT_HAS_SANITIZER_COMMON)
add_subdirectory(sanitizer_common)
- add_subdirectory(cfi)
add_subdirectory(lsan)
add_subdirectory(ubsan)
endif()
+ add_subdirectory(cfi)
+
if(COMPILER_RT_HAS_ASAN)
add_subdirectory(asan)
endif()