summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-06-06 12:35:48 +0000
committerAlexey Samsonov <samsonov@google.com>2013-06-06 12:35:48 +0000
commitdd6605eb299705e09160de7e1f9f505c40e5d1b2 (patch)
tree346894a4a68277b1a52de23c6596e5f3873f3610 /lib/CMakeLists.txt
parent64e2282e9c984c598c93a8bd01983f842e247ce3 (diff)
[ASan] lit tests: create common autogenerated config for running compiler-rt lit tests, and use it in ASan
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@183400 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index f07ab1e18..e504e00aa 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -19,6 +19,10 @@ if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux" AND NOT ANDROID)
add_subdirectory(lsan)
endif()
+configure_lit_site_cfg(
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.common.configured.in
+ ${CMAKE_CURRENT_BINARY_DIR}/lit.common.configured)
+
# The top-level lib directory contains a large amount of C code which provides
# generic implementations of the core runtime library along with optimized
# architecture-specific code in various subdirectories.