summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-11-17 12:18:35 +0000
committerAlexey Samsonov <samsonov@google.com>2013-11-17 12:18:35 +0000
commitce64270a78fac8b4e388756402903757d5ed9103 (patch)
tree350420cc2979d4e921c52e63d636eae657ad393f /lib/CMakeLists.txt
parent3125de9e3048bc505344053d3518cccab7ee6897 (diff)
[ASan] Build ASan on Windows only if MSVC is used
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@194963 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index d4624a692..b620828be 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -7,7 +7,8 @@ if(LLVM_USE_SANITIZER STREQUAL "")
# 32-bit Windows support is experimental.
if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux")
set(SUPPORTS_BUILDING_ASAN TRUE)
- elseif(CMAKE_SYSTEM_NAME MATCHES "Windows" AND CMAKE_SIZEOF_VOID_P EQUAL 4)
+ elseif(CMAKE_SYSTEM_NAME MATCHES "Windows"
+ AND MSVC AND CMAKE_SIZEOF_VOID_P EQUAL 4)
set(SUPPORTS_BUILDING_ASAN TRUE)
else()
set(SUPPORTS_BUILDING_ASAN FALSE)