summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-06-22 16:33:52 +0000
committerAlexey Samsonov <samsonov@google.com>2013-06-22 16:33:52 +0000
commitc3b30b378741f3ec0f4d615ef172b68e1cf97e39 (patch)
tree02ae82449561b0e4b9cdb2bf65471e8b4aaef351 /lib/CMakeLists.txt
parent21e024eb4f1aa3c42bb9dbd1d93a4299807f9555 (diff)
Add cmake rules for building LSan common on Mac OS
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@184639 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index e0780ccbb..a3bc3724f 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -7,6 +7,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux")
add_subdirectory(interception)
add_subdirectory(sanitizer_common)
if(NOT ANDROID)
+ add_subdirectory(lsan)
add_subdirectory(profile)
add_subdirectory(ubsan)
endif()
@@ -16,7 +17,6 @@ if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux" AND NOT ANDROID)
add_subdirectory(tsan)
add_subdirectory(msan)
add_subdirectory(msandr)
- add_subdirectory(lsan)
endif()
# The top-level lib directory contains a large amount of C code which provides