summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorViktor Kutuzov <vkutuzov@accesssoftek.com>2014-04-09 18:45:12 +0000
committerViktor Kutuzov <vkutuzov@accesssoftek.com>2014-04-09 18:45:12 +0000
commitbda6c02b780c19f46e56aaa0806ee4d2af358423 (patch)
tree8302fb2727e306e5c6800b22345e1bab0cba1cf6 /lib/CMakeLists.txt
parent0767a4a70aba7b6aacd18eb08e88924a6b52160a (diff)
Enable building of sanitizers on FreeBSD
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@205919 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index f033e3668..fcde9a20c 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -5,9 +5,9 @@ include(AddCompilerRT)
include(SanitizerUtils)
# Don't build sanitizers in the bootstrap build.
if(NOT LLVM_USE_SANITIZER)
- # AddressSanitizer is supported on Linux and Mac OS X.
+ # AddressSanitizer is supported on Linux, FreeBSD and Mac OS X.
# 32-bit Windows support is experimental.
- if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux")
+ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD")
set(SUPPORTS_BUILDING_ASAN TRUE)
elseif(CMAKE_SYSTEM_NAME MATCHES "Windows"
AND MSVC AND CMAKE_SIZEOF_VOID_P EQUAL 4)
@@ -20,8 +20,8 @@ if(NOT LLVM_USE_SANITIZER)
add_subdirectory(interception)
add_subdirectory(sanitizer_common)
endif()
- if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux" AND NOT ANDROID)
- # LSan, UBsan and profile can be built on Mac OS and Linux.
+ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD" AND NOT ANDROID)
+ # LSan, UBsan and profile can be built on Mac OS, FreeBSD and Linux.
add_subdirectory(lsan)
add_subdirectory(profile)
add_subdirectory(ubsan)