summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-12-10 00:40:58 +0000
committerChris Bieneman <beanz@apple.com>2015-12-10 00:40:58 +0000
commitb336cc19d8bfed34eb80b72947d5274bcaf1bbe4 (patch)
tree231b29661563f162558f6f36dd982b96ba83a362 /lib/CMakeLists.txt
parent4c6b6989f833c5d6738944852bd9327203c12692 (diff)
Revert "[CMake] Provide options for toggling on and off various runtime libraries."
This reverts r255170. This change caused a bunch of bot failures and needs to be revised. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@255184 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt41
1 files changed, 36 insertions, 5 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index d461dffc1..9215b080b 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -9,9 +9,40 @@ if(COMPILER_RT_BUILD_BUILTINS)
endif()
if(COMPILER_RT_BUILD_SANITIZERS)
- message(STATUS "Adding runtimes...")
- foreach(runtime ${COMPILER_RT_RUNTIMES_TO_BUILD})
- message(STATUS "Adding runtime: ${runtime}")
- add_subdirectory(${runtime})
- endforeach()
+ if(COMPILER_RT_HAS_INTERCEPTION)
+ add_subdirectory(interception)
+ endif()
+
+ if(COMPILER_RT_HAS_SANITIZER_COMMON)
+ add_subdirectory(sanitizer_common)
+ add_subdirectory(lsan)
+ add_subdirectory(ubsan)
+ endif()
+
+ add_subdirectory(cfi)
+
+ if(COMPILER_RT_HAS_ASAN)
+ add_subdirectory(asan)
+ endif()
+
+ if(COMPILER_RT_HAS_DFSAN)
+ add_subdirectory(dfsan)
+ endif()
+
+ if(COMPILER_RT_HAS_MSAN)
+ add_subdirectory(msan)
+ endif()
+
+ if(COMPILER_RT_HAS_PROFILE)
+ add_subdirectory(profile)
+ endif()
+
+ if(COMPILER_RT_HAS_TSAN)
+ add_subdirectory(tsan)
+ add_subdirectory(tsan/dd)
+ endif()
+
+ if(COMPILER_RT_HAS_SAFESTACK)
+ add_subdirectory(safestack)
+ endif()
endif()