summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Ricci <francisjricci@gmail.com>2017-06-27 21:10:46 +0000
committerFrancis Ricci <francisjricci@gmail.com>2017-06-27 21:10:46 +0000
commitb24f89116ba057e006bcfa9307544f70fd23af26 (patch)
tree6358761440bf2758843b07b4ff0aecafa079953f /lib/CMakeLists.txt
parent1a427fa56cbea4e65c1f01e25b3cf91da78eadad (diff)
Don't build tsan/dd when COMPILER_RT_HAS_TSAN is false
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@306463 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 83a5acde7..90f72d02a 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -21,6 +21,9 @@ function(compiler_rt_build_runtime runtime)
string(TOUPPER ${runtime} runtime_uppercase)
if(COMPILER_RT_HAS_${runtime_uppercase})
add_subdirectory(${runtime})
+ if(${runtime} STREQUAL tsan)
+ add_subdirectory(tsan/dd)
+ endif()
endif()
endfunction()
@@ -35,9 +38,6 @@ if(COMPILER_RT_BUILD_SANITIZERS)
foreach(sanitizer ${COMPILER_RT_SANITIZERS_TO_BUILD})
compiler_rt_build_runtime(${sanitizer})
- if(${sanitizer} STREQUAL tsan)
- add_subdirectory(tsan/dd)
- endif()
endforeach()
compiler_rt_build_runtime(profile)