summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-11-15 09:09:23 +0000
committerAlexey Samsonov <samsonov@google.com>2013-11-15 09:09:23 +0000
commitaf1a7141afb058e044d4d3c2746abf491771e45b (patch)
tree0c08d4b4cf4be8d9bba400fd79954e47db81f332 /lib/CMakeLists.txt
parentdbd69cc9ccda50efd0305cd0ce9bad50defe4b42 (diff)
Don't build unsupported compiler-rt pieces on Windows
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@194796 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 6aad76794..8b382c140 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -9,7 +9,7 @@ if(LLVM_USE_SANITIZER STREQUAL "")
add_subdirectory(asan)
add_subdirectory(interception)
add_subdirectory(sanitizer_common)
- if(NOT ANDROID AND NOT MSVC)
+ if(NOT ANDROID AND NOT WIN32)
add_subdirectory(lsan)
add_subdirectory(profile)
add_subdirectory(ubsan)
@@ -186,7 +186,7 @@ set(i386_SOURCES
i386/umoddi3.S
${GENERIC_SOURCES})
-if (NOT MSVC)
+if (NOT WIN32)
foreach(arch x86_64 i386)
if(CAN_TARGET_${arch})
add_compiler_rt_static_runtime(clang_rt.${arch} ${arch}