summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-26 07:50:28 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-26 07:50:28 +0000
commit9e8b7b0e07b04c56cc4516d3c989791a99b2f1bd (patch)
tree0f6b27d50af8c856cc3b3982f3304d933755a307 /lib/CMakeLists.txt
parentb09269fff84d71a800e48d8bc0d8e0c38845291c (diff)
Revert r201783 until all FreeBSD fixes are submitted.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@202244 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 6faf88160..1c189c2bc 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -6,9 +6,8 @@ include(SanitizerUtils)
# Don't build sanitizers in the bootstrap build.
if(NOT LLVM_USE_SANITIZER)
# AddressSanitizer is supported on Linux and Mac OS X.
- # FreeBSD port is work-in-progress.
# 32-bit Windows support is experimental.
- if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD")
+ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux")
set(SUPPORTS_BUILDING_ASAN TRUE)
elseif(CMAKE_SYSTEM_NAME MATCHES "Windows"
AND MSVC AND CMAKE_SIZEOF_VOID_P EQUAL 4)
@@ -21,9 +20,8 @@ if(NOT LLVM_USE_SANITIZER)
add_subdirectory(interception)
add_subdirectory(sanitizer_common)
endif()
- if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux|FreeBSD" AND NOT ANDROID)
+ if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux" AND NOT ANDROID)
# LSan, UBsan and profile can be built on Mac OS and Linux.
- # FreeBSD port is work-in-progress.
add_subdirectory(lsan)
add_subdirectory(profile)
add_subdirectory(ubsan)