summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDean Michael Berris <dberris@google.com>2016-07-20 14:14:50 +0000
committerDean Michael Berris <dberris@google.com>2016-07-20 14:14:50 +0000
commit9b1dbf02c9adffedc28c56284967ab87941abb53 (patch)
tree1d50233d892ea15bb6365087fed3e1758f576472 /lib/CMakeLists.txt
parente35e7c00b5c7e7ee5e24d537b80cb0d34cebb038 (diff)
[compiler-rt] [XRay] Basic initialization and flag definition for XRay runtime
Summary: This patch implements the initialisation and patching routines for the XRay runtime, along with the necessary trampolines for function entry/exit handling. For now we only define the basic hooks for allowing an implementation to define a handler that gets run on function entry/exit. We expose a minimal API for controlling the behaviour of the runtime (patching, cleanup, and setting the handler to invoke when instrumenting). Depends on D19904 Reviewers: echristo, kcc, rnk Subscribers: rnk, mehdi_amini, llvm-commits Differential Revision: https://reviews.llvm.org/D21612 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@276117 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index a2b55c4e3..61c56f5b1 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -57,3 +57,7 @@ if(COMPILER_RT_BUILD_SANITIZERS)
add_subdirectory(scudo)
endif()
endif()
+
+if(COMPILER_RT_BUILD_XRAY)
+ add_subdirectory(xray)
+endif()