summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <rnk@google.com>2016-07-20 14:58:07 +0000
committerReid Kleckner <rnk@google.com>2016-07-20 14:58:07 +0000
commit93908cb04a9e06c8b107b3f7f1d829ec28b418b9 (patch)
tree9f150d7df9e485542a665288391bc1a40627b53b /lib/CMakeLists.txt
parent9b0d7caa7159c3ade65cdfc642ab4c20d97d40c4 (diff)
[xray] Only build xray on Linux for now
Should fix the Windows buildbots, and maybe some other non-Linux Unix bots too. XRay currently depends on sanitizer_common, so associate it with the "build sanitizers" option and remove the option for separately controlling the XRay build. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@276124 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 61c56f5b1..1abc6a78a 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -56,8 +56,8 @@ if(COMPILER_RT_BUILD_SANITIZERS)
if(COMPILER_RT_HAS_SCUDO)
add_subdirectory(scudo)
endif()
-endif()
-if(COMPILER_RT_BUILD_XRAY)
- add_subdirectory(xray)
+ if(COMPILER_RT_HAS_XRAY)
+ add_subdirectory(xray)
+ endif()
endif()