summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-12-09 22:45:03 +0000
committerChris Bieneman <beanz@apple.com>2015-12-09 22:45:03 +0000
commit7fbd9917dcc3cb590205331b82d8efc7322de09b (patch)
treed739b38cd8e4037d64487ed66f26b5bc83437860 /lib/CMakeLists.txt
parent30373afde77e6540e2768c164142af7d716cdb03 (diff)
[CMake] Provide options for toggling on and off various runtime libraries.
Summary: Rather than having to add new "experimental" options each time someone wants to work on bringing a sanitizer to a new platform, this patch makes options for all of them. The default values for the options are set by the platform checks that would have enabled them, but they can be overridden on or off. Reviewers: kubabrecka, samsonov Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D14846 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@255170 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt41
1 files changed, 5 insertions, 36 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 9215b080b..d461dffc1 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -9,40 +9,9 @@ if(COMPILER_RT_BUILD_BUILTINS)
endif()
if(COMPILER_RT_BUILD_SANITIZERS)
- if(COMPILER_RT_HAS_INTERCEPTION)
- add_subdirectory(interception)
- endif()
-
- if(COMPILER_RT_HAS_SANITIZER_COMMON)
- add_subdirectory(sanitizer_common)
- add_subdirectory(lsan)
- add_subdirectory(ubsan)
- endif()
-
- add_subdirectory(cfi)
-
- if(COMPILER_RT_HAS_ASAN)
- add_subdirectory(asan)
- endif()
-
- if(COMPILER_RT_HAS_DFSAN)
- add_subdirectory(dfsan)
- endif()
-
- if(COMPILER_RT_HAS_MSAN)
- add_subdirectory(msan)
- endif()
-
- if(COMPILER_RT_HAS_PROFILE)
- add_subdirectory(profile)
- endif()
-
- if(COMPILER_RT_HAS_TSAN)
- add_subdirectory(tsan)
- add_subdirectory(tsan/dd)
- endif()
-
- if(COMPILER_RT_HAS_SAFESTACK)
- add_subdirectory(safestack)
- endif()
+ message(STATUS "Adding runtimes...")
+ foreach(runtime ${COMPILER_RT_RUNTIMES_TO_BUILD})
+ message(STATUS "Adding runtime: ${runtime}")
+ add_subdirectory(${runtime})
+ endforeach()
endif()