summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2017-09-18 18:13:47 +0000
committerVedant Kumar <vsk@apple.com>2017-09-18 18:13:47 +0000
commit6a0bc1fdc9f713f4cc9a89866dab7d66135519a9 (patch)
tree54469e6ba5c28f49c8fdfe027e06b3988406f45d /lib/CMakeLists.txt
parentf951abe9908d2034b99e579e8b88afab5b7a7d24 (diff)
[cmake] Make it possible to build and test profile without sanitizers
This should fix an issue which arises when running check-compiler-rt on the coverage bot: http://green.lab.llvm.org/green/job/clang-stage2-coverage-R_build/1590/ The bot doesn't build the sanitizers, but the check-compiler-rt target always expects the profile runtime to exist. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@313549 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 025320f47..a92d0a3f0 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -39,7 +39,9 @@ if(COMPILER_RT_BUILD_SANITIZERS)
foreach(sanitizer ${COMPILER_RT_SANITIZERS_TO_BUILD})
compiler_rt_build_runtime(${sanitizer})
endforeach()
+endif()
+if (COMPILER_RT_HAS_PROFILE)
compiler_rt_build_runtime(profile)
endif()